w.bloggar failing with error -2147217887

it was returning an error code -2147217887, and I believe this *may* have been because of brackets (now removed) from one of the blog titles. I say may because I also went through and republished all blogs and archives at the same time, just to make sure I wasn’t missing anything

update: just been having the same problems again, and there were no brackets. This time i managaed to pin it down to a particular blog name:

“linux install :: on time m series notebook” fails
“linux install :: time m series notebook” doesn’t

i’m sure there’s a reason for it but…..

UPDATE: 06 Jan 2004 – just discovered that it was because of the length which was limited to 40 chars – I just edited the function getUsersBlogs in listen.asp. I didn’t realise until now that the error messgaes are generated by blogworks rather than w.blogger

Tags: Uncategorised

the cats hate me

because I make them wear huge plastic collars to stop them pulling their stitches out.

unhappy bunnies
Tags: Uncategorised

blogworks failing

with the following error:-

Microsoft VBScript runtime  error '800a01a8'

Object required: 'xmlRoot'

/admin_dir/xmlsubs.asp, line 477

I believe this is something to do with editing a post from a previous month, when there are no posts for the current month. The scripts are possibly looking for an archive file for the current month and it doesn’t exist, so the XMLRoot object is not created.

Tags: Uncategorised

windows XP keyboard mapping

sometimes I think I don’t deserve a career in IT – I just spent a good half an hour completely stumped as to how to change the keyboard mapping from US to UK on a win XP box!

To do this, go to control panel ->regional and language options->languages->text services and input languages

obvious when you look at it, but could I find it?

archived comments

Thankyou I’ve just been struggling too.

Chris Parkinson 2007-03-12 20:29:53

Thank you. It’s not easy to find. I added English (Ireland) but had to remove the entry for US to get the correct mappings for @ and “.

Mick Ruddy 2007-05-09 22:19:24

Thanks, worked perfectly.

Carl Dennis 2008-01-18 16:02:16

Hi i am looking for the divide button on my laptop on a uk keyboard can you help ??

Robin 2009-07-25 00:43:00

Many thanks to you and to Mick Ruddy. I had tried adding the UK keyboard to my Dell previously, but thought I could switch between them – didn’t realize I had to delete the US keyboard before the UK one would work properly.

G Robert Thompson 2009-10-07 15:04:32

I rebuilt my PC a year ago and since then it thought it was US setting – despite the obvious regional settings pointing at the UK

The Key board was always mapped wrong so the @ sign was always at SHift-2

This info here fixed it – thats great – the simplest things make the world go round…

Thanks Dude

James 2009-10-17 11:01:19

Tags: Uncategorised

troubleshooting section

I always seem to find myself coming up against the same problems, fixing them then forgetting how I did it when I get the same problem. Hopefully by logging problems here it will help me remember, and help out other people at the same time

Tags: Uncategorised

Mentor PCMCIA fast ethernet card drivers

I installed windows XP today and could not get my mentor PCMCIA PCMLAN10/100 fast ethernet network card to work using downloaded drivers from the vendors website.

I searched around the web a bit and found loads of other people with the same problem. It turns out that there are different versions of this card, and what looks like the same card is different.

I eventually got it working by digging out the original diskette that came with the card and pointing XP at the w2k driver on that – now working fine (so far).

If you have found this via a search and are having the same problem, and your card is recognised by the machine as “PCMCIA Fast-Ethernet” then you need the original drivers, rather than the ones on the mentor site.

If you are looking for linux information for the same card – I have had this card working under linux too

Tags: Uncategorised

w.bloggar working

After a lot of messing around I have managed to get the w.bloggar v3.00 interface working so I can blog straight from the desktop.

wbloggar GUI
Tags: Uncategorised

wap interface for blogworks

I’ve been reading about mobile blogging, and whilst I don’t have a fancy phone with pictures etc, it would be quite nice to have a way to make text postings. My phone (sony j5e) has ms mobile explorer – a wap and basic HTML browser, so it shouldn’t be too difficult to build a simplified HTML interface which works with blogworks.

Ideally I should learn more about the blogger API and have it speak to this rather than directly to the files – possibly making it more universal.

Tags: Uncategorised